您的位置:首页 > 其它

1069. The Black Hole of Numbers (20)

2015-12-06 11:26 309 查看
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089 9810 - 0189 = 9621 9621 - 1269 = 8352 8532 - 2358 = 61747641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:[/b]
6767
Sample Output 1:[/b]
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:[/b]
2222
Sample Output 2:[/b]
2222 - 2222 = 0000

来源: <http://www.patest.cn/contests/pat-a-practise/1069>

#include<stdio.h>

#include <iostream>

#include <algorithm>

#include <vector>

#pragma warning(disable:4996)


using namespace std;

vector<int> num;


bool cmp(int a, int b) {

return a < b;

}


int main(void) {

int n,result=-1;

int temp;

int high, low;

cin >> n;

temp = n;

while (1) {

num.clear();

while (temp>0) {

num.push_back(temp % 10);

temp = temp / 10;

}

if (num.size() < 4)

for (int i = num.size(); i < 4; i++)

num.push_back(0);


sort(num.begin(), num.end(), cmp);

low = num[0] * 1000 + num[1] * 100 + num[2] * 10 + num[3];

high = num[3] * 1000 + num[2] * 100 + num[1] * 10 + num[0];

result = high - low;

printf("%04d - %04d = %04d\n", high, low, result);

if (result == 6174 || result == 0)

break;

temp = result;

}

return 0;


}

[/code]

来自为知笔记(Wiz)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: