您的位置:首页 > 其它

1069. The Black Hole of Numbers (20)

2017-07-25 22:00 357 查看
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089

9810 - 0189 = 9621

9621 - 1269 = 8352

8532 - 2358 = 6174

7641 - 1467 = 6174

… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.


Input Specification:


Each input file contains one test case which gives a positive integer N in the range (0, 10000).


Output Specification:


If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767


Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174


Sample Input 2:
2222


Sample Output 2:
2222 - 2222 = 0000


#include <cstdio>
#include <algorithm>
using namespace std;
int inc, de;
void gao(int x){
int a[4];
a[0] = x / 1000;
a[1] = x / 100 % 10;
a[2] = x / 10 % 10;
a[3] = x % 10;
sort(a, a + 4);
inc = a[0] * 1000 + a[1] * 100 + a[2] * 10 + a[3];
de = a[3] * 1000 + a[2] * 100 + a[1] * 10 + a[0];
}
int main(){
int n, s;
scanf("%d", &n);
if ((n / 1000 == n / 100 % 10) && (n / 1000 == n / 10 % 10) && (n / 1000 == n % 10)){
printf("%04d - %04d = 0000\n", n, n);
return 0;
}
do{
gao(n);
s = de - inc;
printf("%04d - %04d = %04d\n", de, inc, s);
n = s;
} while (s != 6174);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: