您的位置:首页 > 其它

HDU2051_Bitset

2016-12-05 19:09 316 查看


Bitset

http://acm.hdu.edu.cn/showproblem.php?pid=2051

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 21577    Accepted Submission(s): 16009


Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

 

Input

For each case there is a postive number n on base ten, end of file.

 

Output

For each case output a number on base two.

 

Sample Input

1
2
3

 

Sample Output

1
10
11

 

Author

8600 && xhd

 

Source

校庆杯Warm Up

#include <stdio.h>
int bin[100]={0};
int len=0;

int sub(int x)
{
if (x!=0)
{
bin[len++]=x%2;
return sub(x/2);
}
else
len--;
}

int main()
{
int n,i;
while (scanf ("%d",&n)!=EOF)
{
len=0;
sub(n);
for (i=len;i>=0;i--)
printf ("%d",bin[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM recursion