您的位置:首页 > 其它

HDU2051 Bitset

2013-03-09 14:09 232 查看


点击打开链接
 

Bitset

[b]Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9132    Accepted Submission(s): 7037
[/b]

[align=left]Problem Description[/align]
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

[align=left]Input[/align]
For each case there is a postive number n on base ten, end of file.
 

 

[align=left]Output[/align]
For each case output a number on base two.
 

 

[align=left]Sample Input[/align]

1
2
3

 

 

[align=left]Sample Output[/align]

1
10
11

 

 

[align=left]Author[/align]
8600 && xhd
 

 

[align=left]Source[/align]
校庆杯Warm Up
 

 

[align=left]Recommend[/align]
linle
 
 
这道题用栈比较好做。
 
 
#include<stdio.h>
#include<iostream>
#include<stack>
using namespace std;
int main()
{
int m;
stack<int> z;
while(scanf("%d",&m)!=EOF)
{
int x=m;
while(x>0)
{
z.push(x%2);
x/=2;
}
while(!z.empty())
{
cout<<z.top();
z.pop();
}
printf("\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: