您的位置:首页 > 其它

Bitset[HDU2051]

2013-08-13 10:37 337 查看

Bitset

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10007 Accepted Submission(s): 7749


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)

Input
For each case there is a postive number n on base ten, end of file.

Output
For each case output a number on base two.

Sample Input
1
2
3

Sample Output
1
10
11

Author
8600 && xhd

Source
校庆杯Warm Up

Recommend
linle

除2倒取余数

#include<stdio.h>
int main()
{
int p[50],x,i;
while (scanf("%d",&x)!=EOF)
{
int cnt=0;
while (x)
{
p[cnt++]=x&1;
x>>=1;
}
for (i=cnt-1;i>=0;i--) printf("%d",p[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: