您的位置:首页 > 大数据 > 人工智能

51nod-【1787 GCD Again】

2016-12-03 14:54 148 查看


GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3074    Accepted Submission(s): 1353


Problem Description

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?

No? Oh, you must do this when you want to become a "Big Cattle".

Now you will find that this problem is so familiar:

The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little
more difficult problem: 

Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.

This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.

Good Luck!

 

Input

Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.

 

Output

For each integers N you should output the number of integers M in one line, and with one line of output for each line in input. 

 

Sample Input

2
4
0

 

Sample Output

0
1用 long long ,不然不会ac的 

#include<cstdio>
typedef long long LL;
int main()
{
LL n;
while(~scanf("%lld",&n)&&n)
{
LL i,ans=n,sum=n;
for(i=2;i*i<=n;++i)
{
if(n%i==0)
{
ans=ans*(i-1)/i;//这个地方需要小心会超int
while(n%i==0)
n/=i;
}
}
if(n!=1)
ans=ans*(n-1)/n;
printf("%lld\n",sum-1-ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: