您的位置:首页 > 其它

(POJ1836)Alignment <DP,最长上升子序列变形>

2016-11-24 16:02 330 查看
Alignment

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , … , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line’s extremity (left or right). A soldier see an extremity if there isn’t any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:

• 2 <= n <= 1000

• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8

1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source

Romania OI 2002

题意:

有n个士兵排成一排,他们按照编号1…n排列,现在可以让一些士兵出列,使还留在队列的士兵都可以看到端点(左端或右端),即从左端或右端到每个士兵没有比他高的或一样高的士兵存在。

分析:

题目就是说求出一个最长的先是单调递增后是单调递减的子序列的长度m,答案就是n-m.

所以我们可以按照求最长上升子序列的方法求出最长上升子序列dp1[i]的值,和最长下降子序列dp2[i]的值。

注意:dp1[i]表示在1~i中的子序列且结尾为a[i]的最长递增子序列的最大长度

所以我们要求出最长递增和最长递减的和dp1[i]+dp2[j]的最大值时,要讨论所有的可能。

刚开始以为答案是n-max(dp1[i]+dp2[i+1]),后来好好想了下最长上升子序列求解的过程才想明白

这题使我对最长上升子序列算法的理解更深了

分析:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 1010;
double a[maxn];
int dp1[maxn],dp2[maxn];
int n;

int main()
{
while(scanf("%d",&n)!=EOF)
{
for(int i=1;i<=n;i++)
dp1[i] = dp2[i] = 1;
for(int i=1;i<=n;i++)
scanf("%lf",&a[i]);
//
for(int i=2;i<=n;i++)
{
for(int j=1;j<i;j++)
{
if(a[j] < a[i] && dp1[j]+1 > dp1[i])
dp1[i] = dp1[j] + 1;
}
}
//
for(int i=n-1;i>=1;i--)
{
for(int j=n;j>i;j--)
{
if(a[i] > a[j] && dp2[j] + 1 > dp2[i])
dp2[i] = dp2[j] + 1;
}
}
//
int ans = 1010;
for(int i=1;i<=n;i++)
{
for(int j=i+1;j<=n;j++)
ans = min(ans,n-(dp1[i]+dp2[j]));
}
printf("%d\n",ans);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: