您的位置:首页 > 其它

hdu 1025 Constructing Roads In JGShining's Kingdom 深夜又一波DP,最长上升子序列(O(nlogn)算法)!尼玛坑爹的输出啊!!

2015-02-09 22:27 716 查看

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17189 Accepted Submission(s): 4878



Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource.
You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor
cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^



Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to
the end of file.



Output
For each test case, output the result in the form of sample.

You should tell JGShining what's the maximal number of road(s) can be built.



Sample Input
2
1 2
2 1
3
1 2
2 3
3 1




Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

	哎,先上一个博客最长上升子序列nlogn算法	一般别人有写的比较好的,,我就直接推荐给你们了,自己再去分析,,就是浪费时间看了。	你们认为这道题的难点在哪?O(nlog(n))算法的状态转移方程?	nonono,,最重要的就是细心,尼玛,我会告诉你当最长子串的长度不一样时,单词的单复数也要改变的嘛!!!!road的词性需要改变。。。不信你看两个输出样例。。出题人真蛋疼。。不看discuss,估计我还会wrong一辈子..哎,防不胜防啊下面直接代码:
#include <stdio.h>
#define MAX 500100

int num[MAX] , rem[MAX];

int max(int a , int b)
{
	return a>b?a:b ;
}

int Bsearch(int start,int end,int des)
{
	int s = start,e=end;
	while(s<e)
	{
		int mid = (s+e)>>1 ;
		if(des>rem[mid])	s = mid+1;
		else	e = mid ;
	}
	return s ;
}
int main()
{
	int n , c = 1;
	while(scanf("%d",&n) != EOF)
	{
		for(int i = 1 ; i <= n ; ++i)
		{
			int index ,data ;
			scanf("%d%d",&index,&data) ;
			num[index] = data ;
			rem[index] = 0 ;
		}
		rem[0] = 0 ;
		int len = 0 ;
		for(int i = 1 ; i <= n ; ++i)
		{
			int index = Bsearch(0,len-1,num[i]);
			if(rem[index]>num[i])
			{
				rem[index] = num[i] ;
			}
			else rem[len++] = num[i] ;
		}
		printf("Case %d:\n",c++);
		if(len==1)
			printf("My king, at most 1 road can be built.\n\n");
		else	printf("My king, at most %d roads can be built.\n\n",len);
	}
	return 0 ;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐