您的位置:首页 > 其它

【POJ 3071 Football】+ 概率DP

2016-11-21 13:46 357 查看
Football

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 5015 Accepted: 2557

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2

0.0 0.1 0.2 0.3

0.9 0.0 0.4 0.5

0.8 0.6 0.0 0.6

0.7 0.5 0.4 0.0

-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)

= p21p34p23 + p21p43p24

= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

题意 : 给出2 ^ n 个球队 和 2 ^ n 场比赛, 求得冠军概率最大的那支球队

思路 : 全概率公式~dp[i][j] 表示第i场比赛 第 j 支球队 获胜的概率~很容易想到~第 j 支球队若想在 第 i 场比赛中获胜~必须在 i - 1 场中获胜~且 j 的对手 k 也必须在 i - 1 场比赛中获胜~然后判断 j 和 k 之间是否有对决即可~

AC代码 :

#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = (1 << 7) + 10;
double dp[8][MAXN],p[MAXN][MAXN];
int main()
{
int n;
while(scanf("%d",&n) != EOF && n != -1){
for(int i = 0 ; i < (1 << n) ; i++)
for(int j = 0 ; j < (1 << n) ; j++)
scanf("%lf",&p[i][j]);
memset(dp,0,sizeof(dp));
for(int i = 0 ; i < (1 << n) ; i++) dp[0][i] = 1.0;
for(int i = 1 ; i <= n ; i++)
for(int j = 0 ; j < (1 << n) ; j++)
for(int k = 0 ; k < (1 << n) ; k++)
if(((j >> (i - 1)) ^ 1) == (k >> (i - 1))) // j 和 k 之间是否有对决
dp[i][j] += dp[i - 1][j] * dp[i - 1][k] * p[j][k]; // j 和 k 在上场都胜时才有机会对决
int ans = 0;
for(int i = 1 ; i < (1 << n) ; i++) // 更新最优解
if(dp
[i] > dp
[ans])
ans = i;
printf("%d\n",++ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp