您的位置:首页 > 产品设计 > UI/UE

HDU 1387 Team Queue(团队队列,优先队列)

2016-11-16 19:48 375 查看


http://acm.hdu.edu.cn/showproblem.php?pid=1387


Team Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2009    Accepted Submission(s): 696


Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them.
If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue. 

 

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers
in the range 0 - 999999. A team may consist of up to 1000 elements. 

Finally, a list of commands follows. There are three different kinds of commands: 

ENQUEUE x - enter element x into the team queue 

DEQUEUE - process the first element and remove it from the queue 

STOP - end of test case 

The input will be terminated by a value of 0 for t. 

 

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

 

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

 

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

 

Source

University of Ulm Local Contest 1998

题意:

多个队伍排队,三种操作:

ENQUEUE x -  x 进队

DEQUEUE - 输出出对的元素 

STOP - 终止操作

此时的队列是优先队列,所在队伍在前的a元素,无论a什么时候进队,如果出队,就是 a 优先。

思路:

最初用容器,其实队伍不只是两个,思路的不完整导致繁琐!

优先队列模拟、
AC CODE:

#include<stdio.h>
#include<cstring>
#include<queue>
#include<algorithm>
#define HardBoy main()
#define ForMyLove return 0;
using namespace std;
const int MYDD = 1103 + 1e6;

int c[1103], vis[1103], f[MYDD];
struct prio {
int w, m;
int name;
bool operator <(const prio a)const {
if(w==a.w)return m>a.m;
return w>a.w;
}
} in;

int HardBoy {
int t, kc = 1;
while(scanf("%d", &t) && t) {
char oper[11];
priority_queue<prio> q;
memset(f,0,sizeof(f));
memset(c,0,sizeof(c));

for(int j = 0; j < t; j++) {
int n, a;
scanf("%d",&n);
for(int k = 0; k < n; k++) {
scanf("%d",&a);
f[a]=j;
}
}

int cnt=0, num = 0;
printf("Scenario #%d\n", kc++);
while(scanf("%s", oper)) {
if(!strcmp(oper,"STOP")) break;
if(!strcmp(oper,"ENQUEUE")) {
int dd;
scanf("%d", &dd);
if(c[f[dd]]) {
c[f[dd]]++;
in.w = vis[f[dd]];
in.name = dd;
in.m = cnt++;
q.push(in);
} else {
c[f[dd]]++;
vis[f[dd]] = num;
in.w = num++;
in.name = dd;
in.m = cnt++;
q.push(in);
}
} else {
in = q.top();
q.pop();
printf("%d\n", in.name);
c[f[in.name]]--;
}
}
printf("\n");
}
ForMyLove
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: