您的位置:首页 > 产品设计 > UI/UE

HDU 1387 Team Queue( 单向链表 )

2015-01-08 01:33 323 查看

Team Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1294 Accepted Submission(s): 442


[align=left]Problem Description[/align]
Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

[align=left]Input[/align]
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

[align=left]Output[/align]
For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

[align=left]Sample Input[/align]

2

3 101 102 103
3 201 202 203

ENQUEUE 101

ENQUEUE 201
ENQUEUE 102

ENQUEUE 202
ENQUEUE 103

ENQUEUE 203
DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE
DEQUEUE
DEQUEUE

STOP
2

5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006

ENQUEUE 259001
ENQUEUE 260001

ENQUEUE 259002

ENQUEUE 259003

ENQUEUE 259004

ENQUEUE 259005
DEQUEUE

DEQUEUE
ENQUEUE 260002
ENQUEUE 260003

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE
STOP
0

[align=left]Sample Output[/align]

Scenario #1

101
102

103

201

202

203

Scenario #2

259001

259002

259003

259004

259005

260001

以为要在过程中插入数字,若然是用数组来模拟的话必然超时 O( n = 1000*1000 ) 一次操作。
带插入,直接用一个单向链表即可。
记录 0 ~ 999999 所属的组 。
记录任意组在队列中最后一个元素 。 没有的话用-1表示
入出队时记得完整地更新好这几个数组就ok了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <algorithm>
using namespace std;
#define root 1,n,1
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define lr rt<<1
#define rr rt<<1|1
typedef long long LL;
typedef pair<int,int>pii;
#define X first
#define Y second
const int oo = 1e9+7;
const double PI = acos(-1.0);
const double eps = 1e-6 ;
const int N = 1000010 ;
const int mod = 1007;
int t , n , head , tail ;
int num
, nxt
, team_last
, belong
;

void Init() {
memset( nxt , -1 ,sizeof nxt );
memset( team_last , -1 ,sizeof team_last );
memset( belong , -1 ,sizeof belong );
head = tail = -1 ;
}

void Push1( int x ) {
if( head == -1 ) {
head = tail = x ;
nxt[x] = -1 ;
}
else {
nxt[tail] = x ;
nxt[x] =-1 ;
tail = x ;
}
}
void Push2( int x , int last , int team ) {
nxt[x] = nxt[last];
nxt[last] = x ;
team_last[team] = x ;
if( nxt[x] == -1 ) tail = x ;
}
void Run() {
Init(); int x ;
for( int i = 1 ; i <= t ; ++i ) {
cin >> n ;
for( int j = 0 ; j < n ; ++j ){
cin >> x ; belong[x] = i ;
}
}
string s ;
while( cin >> s ) {
if( s[0] == 'S' ) break ;
else if( s[0] == 'E' ) {
cin >> x ;
if( belong[x] == -1 ) Push1(x);
else {
if( team_last[belong[x]] == -1 ) Push1(x) , team_last[belong[x]] = x ;
else Push2(x,team_last[belong[x]],belong[x]);
}
}
else {
cout << head << endl ;
if( team_last[belong[head]] == head ) team_last[belong[head]] = -1 ;
head = nxt[head] ;
}
}
}
int main()
{
#ifdef LOCAL
freopen("in.txt","r",stdin);
#endif // LOCAL
ios::sync_with_stdio(false);
int _  , cas = 1 ; //cin >> _ ;
while( cin >> t && t ) {
cout << "Scenario #" << cas++ << endl ;
Run(); cout << endl ;
}
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: