您的位置:首页 > 产品设计 > UI/UE

HDU 1387 Team Queue (队列模拟)

2017-05-16 17:23 441 查看

Team Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 140 Accepted Submission(s): 66
 
Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them.
If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue. 

 
Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers
in the range 0 - 999999. A team may consist of up to 1000 elements. 

Finally, a list of commands follows. There are three different kinds of commands: 

ENQUEUE x - enter element x into the team queue 

DEQUEUE - process the first element and remove it from the queue 

STOP - end of test case 

The input will be terminated by a value of 0 for t. 

 
Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case
4000
, even after the last one. 

 
Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0


 
Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001


 
 
Source

University of Ulm Local Contest 1998
 
题意给出队伍的信息跟队伍中个体的编号,然后先按照队伍的先后、再按照队伍中个体的先后进行输出。 有种插队的感觉(

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <string>
#include <vector>
#include <string.h>
#include <memory>
#include <queue>
#include <stack>
#include <map>
using namespace std;
int main () {

map<int, int> mp;
char str[20];
int t, n, p;
int cn = 1;
while (cin >> t && t) {
mp.clear();
cout << "Scenario #" << cn++ << endl;
for (int i = 0; i < t; ++i) {
cin >> n;
while (n--) {
cin >> p;
mp[p] = i;
}
}
queue<int> que[1005];
queue<int> ans;
while (cin >> str && str[0] != 'S') {
if (str[0] == 'E') {
cin >> p;
int id = mp[p];
if (que[id].empty()) {
ans.push(id);
}
que[id].push(p);
} else if (str[0] == 'D') {
int id = ans.front();
cout << que[id].front() << endl;
que[id].pop();
if (que[id].empty())
ans.pop();
}
}
cout << endl;
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: