您的位置:首页 > 其它

hdu1002 大大大整数加法 A + B Problem II

2016-10-24 18:40 337 查看
java的BigInterger也会wa。。。。直接做成字符串相加。。。

浪费了一会儿生命。。。。

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 324461 Accepted Submission(s): 63039



[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


[align=left]Author[/align]
Ignatius.L

#include<iostream>
#include<string>
#include<fstream>
#define N 1000
using namespace std;

string bigmult(string a,string b)
{
int la,lb,lc,i,j,flag;
string c="";
char t;
i=la=a.length()-1;
j=lb=b.length()-1;
flag=0;
while(i>=0&&j>=0)
{
t=a[i]+b[j]+flag-'0';
if(t>'9')
{
t=t-10;flag=1;
}
else flag=0;
c+=t;
i--;j--;
}
while(i>=0)
{
t=a[i]+flag;
if(t>'9')
{
t=t-10;flag=1;
}
else flag=0;
c+=t;
i--;
}
while(j>=0)
{
t=b[j]+flag;
if(t>'9')
{
t=t-10;flag=1;
}
else flag=0;
c+=t;
j--;
}
if(flag) c+=(flag+'0');
lc=c.length();
for(i=0,j=lc-1;i<j;i++,j--)
{
t=c[i];c[i]=c[j];c[j]=t;
}
return c;
}

string ans
;

int main()
{
int test,rnd=1;
string a,b;
cin>>test;
while(test--){
cin>>a>>b;
printf("Case %d:\n",rnd);
rnd++;
cout<<a<<" + "<<b<<" = "<<bigmult(a,b)<<endl;
if(test!=0){
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: