您的位置:首页 > 其它

hdu 1002 高精度加法

2015-05-19 22:21 246 查看


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 254093    Accepted Submission(s): 49006


Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

 

Sample Input

2
1 2
112233445566778899 998877665544332211

 

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 

Author

Ignatius.L

 

Recommend

 

思路:①倒置对齐②逐位相加③逐位检查是否大于9,若大于9,则施行进位④重新倒置输出 

#include<stdio.h>
#include<string.h>
#define min(x,y) (x<=y?x:y)
#define maxn 1001
int main()
{
int a,last,len1,len2,x[maxn],y[maxn],k,i,j;
char b[maxn],c[maxn];
scanf("%d",&a);
for(j=1;j<=a;j++)
{
x[0]=0;
y[0]=0;
scanf("%s%s",b,c);
len1=strlen(b);
len2=strlen(c);
for(i=len1-1;i>=0;i--)
{
x[0]++;
x[x[0]]=b[i]-'0';
}
for(i=len2-1;i>=0;i--)
{
y[0]++;
y[y[0]]=c[i]-'0';
}
last=0;
k=min(x[0],y[0]);
for(i=1;i<=k;i++)
{
x[i]+=y[i]+last;
last=x[i]/10;
x[i]=x[i]%10;
}
if(len1>k)
{
for(i=k+1;i<=len1;i++)
if(last>0)
{
x[i]+=last;
last=x[i]/10;
x[i]%=10;
}
}
if(len2>k)
{
for(x[0]=y[0],i=k+1;i<=len2;i++)
{
x[i]=y[i]+last;
last=x[i]/10;
x[i]%=10;
}
}
printf("Case %d:\n",j);
printf("%s + %s = ",b,c);
for(i=x[0];i>=1;i--)
{
printf("%d",x[i]);
}
if(j!=a)
{
printf("\n\n");
}
else
{
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c hdu1002