您的位置:首页 > 其它

POJ3278-Catch That Cow

2016-09-28 11:19 204 查看

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

题解

暴力BFS加暴力剪枝就水过去了。

三种状态:

前进1

后退1

当前坐标*2

直接BFS三种状态,如果跑得太远了就不用再搜索了。

这时候数组空间开大一点,毕竟上限不明确。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

int n,k,time[10000010];
queue<int>q;

void bfs(int s)
{
memset(time,0x3f,sizeof(time));
time[s]=0;
q.push(s);
while(!q.empty())
{
int t=q.front();
q.pop();
if(t==k) return ;
if(time[t-1]>time[t]+1)
{
q.push(t-1);
time[t-1]=time[t]+1;
}
if(time[t+1]>time[t]+1&&t<=k*2)
{
q.push(t+1);
time[t+1]=time[t]+1;
}
if(time[t*2]>time[t]+1&&t<=k*2)
{
q.push(t*2);
time[t*2]=time[t]+1;
}
}
}

int main()
{
scanf("%d%d",&n,&k);
bfs(n);
printf("%d",time[k]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj