您的位置:首页 > 其它

POJ-3278-Catch That Cow

2016-07-26 22:07 316 查看
Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 74205 Accepted: 23391
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
int n, k;
struct node
{
int data;
int step;
}q, p;
int main()
{
bool vis[100010];
memset(vis, 0, sizeof(vis));
scanf("%d %d", &n, &k);
queue<node>qq;
q.data = n;
q.step = 0;
qq.push(q);
while(!qq.empty())
{
q = qq.front();
qq.pop();
if(q.data==k)
{
printf("%d\n",q.step);
break;
}
p.step = q.step+1;
vis[q.data] = 1;
p.data = q.data+1;
if(p.data<=100000&&p.data>=0&&!vis[p.data])qq.push(p);
p.data = q.data-1;
if(p.data<=100000&&p.data>=0&&!vis[p.data])qq.push(p);
p.data = q.data*2;
if(p.data<=100000&&p.data>=0&&!vis[p.data])qq.push(p);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: