您的位置:首页 > 其它

POJ 3468 A Simple Problem with Integers(线段树区间修改)

2016-09-05 20:50 435 查看
A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072KB 64bit IO Format: %lld & %llu
Submit Status

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is
to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4


Sample Output

4
55
9
15


Hint

The sums may exceed the range of 32-bit integers.

大意:对于每个C询问,将区间[a,b]上的元素都加c;对于每个Q询问,输出区间[a,b]的和。

思路:简单的线段树区间更新。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<vector>
#include<algorithm>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define lc rt<<1
#define rc rt<<1|1
using namespace std;

typedef long long ll;
const int maxn = 200000 + 10;
const int INF = 1e9 + 10;
ll sum[maxn],add[maxn],ans;

void PushUp(int rt)
{
sum[rt] = sum[lc] + sum[rc];
}

void PushDown(int rt, int m)
{
if (add[rt]) {
add[lc] += add[rt];
add[rc] += add[rt];
sum[lc] += add[rt] * (m - (m >> 1));
sum[rc] += add[rt] * (m >> 1);
add[rt] = 0;
}
}

void build(int l, int r, int rt)
{
if (l == r) scanf("%lld",&sum[rt]);
else {
int m = (l + r) >> 1;
build(lson);
build(rson);
PushUp(rt);
}
}

void update(int ql, int qr, int c, int l, int r, int rt)
{
if (ql <= l && r <= qr) { //如果完全覆盖,那么暂时不更新子结点,因为暂时不会用到,以节省时间。
add[rt] += c;
sum[rt] += (ll)c*(r-l+1);
return;
}
//如果没有完全覆盖,则要考虑左右子结点,这时要先把左右子结点更新一下再操作
PushDown(rt, r-l+1);
int m = (l + r) >> 1;
if (ql <= m) update(ql, qr, c, lson);
if (m < qr) update(ql, qr, c, rson);
//因为子结点已经被修改,最后更新父节点
PushUp(rt);
}

ll query(int ql, int qr, int l, int r, int rt)
{
if (ql <= l && r <= qr) {
return sum[rt];
}

PushDown(rt, r-l+1);
int m = (l + r) >> 1;
ll ans = 0;
if (ql <= m) ans += query(ql, qr, lson);
if (m < qr) ans += query(ql, qr, rson);
//这里不用再更新sum[rt],因为这时的sum[rt]就是真实的区间和
return ans;
}

int main()
{
int n,q;
scanf("%d%d",&n,&q);
build(1,n,1);
while(q--) {
char s[2];
scanf("%s",s);
int a,b,c;
if (s[0] == 'Q') {
s
a2da
canf("%d%d",&a,&b);
ll ans = query(a,b,1,n,1);
printf("%lld\n",ans);
}
else {
scanf("%d%d%d",&a,&b,&c);
update(a,b,c,1,n,1);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: