您的位置:首页 > 其它

【DP】poj1651 <矩阵链乘法>

2016-08-28 22:00 399 查看
Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product
of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5


Sample Output

3650


题意:就是n个数,每次从除去首尾两个数的其他数中选一个数和挨着的两边的数相乘得到一个值,然后每次求的值相加,按照这种方法求解一个最小的值。

思路:肯定会想到暴力,但是时间复杂度是指数级的,肯定会tle。看了看书,发现这是一个很裸的矩阵链乘法的题目,收藏一下此题,在仔细看一下这个算法。

【参考代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

int n,a[105],dp[105][105],j,k;

int main()
{
while(~scanf("%d",&n)) {
for(int i=1;i<=n;i++) scanf("%d",&a[i]);
memset(dp,0,sizeof(dp));
for(int l=2;l<n;l++) {
for(int i=2;i<=n-l+1;i++) {
j=i+l-1;
dp[i][j]=INF;
for(k=i;k<j;k++)
dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*a[j]);
}
}
printf("%d\n",dp[2]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: