您的位置:首页 > 其它

Message Flood 【排序--二分查找】

2016-08-18 17:13 260 查看

Message Flood


Time Limit: 1500ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What
a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin
has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs
to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed
to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the
length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0


示例输出

3


#include<bits/stdc++.h>
using namespace std;
string a[20010];
bool found[20010];

bool Bin_search(string str,int start,int end)  //二分法查找
{
int mid;
while(start<=end)
{
mid = (start+end)/2;
if(str==a[mid])
{
if(!found[mid])
{
found[mid]=true;
return true;
}
else
return false;
}
else if(str<a[mid])
end = mid-1;
else
start = mid+1;
}
return false;
}
int main()
{
int n,m;
string str;
while(cin>>n&&n)
{
cin>>m;
memset(found,false,sizeof(found)); //标记是否已经发送过信息
for(int i=0;i<n;i++)
{
cin>>a[i];
for(int j=0;j<a[i].length();j++)//将名字字符串中的大写转为小写
a[i][j]=tolower(a[i][j]);
}
int  cunt = n;
sort(a,a+n); //按字典序排序
while(m--)
{
cin>>str;
for(int j=0;j<str.length();j++)
str[j]=tolower(str[j]);
if(Bin_search(str,0,n-1))
cunt--;
}
cout<<cunt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: