您的位置:首页 > 其它

文章标题 HDU 5584:LCM Walk(数学推导)

2016-08-09 19:16 453 查看

LCM Walk

Description

A frog has just learned some number theory, and can’t wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)!

Input

First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers ex and ey, which is the destination grid.

⋅ 1≤T≤1000.

⋅ 1≤ex,ey≤109.

Output

For every test case, you should output ” Case #x: y”, where x indicates the case number and counts from 1 and y is the number of possible starting grids.

Sample Input

3

6 10

6 8

2 8

Sample Output

Case #1: 1

Case #2: 2

Case #3: 3

题意:一个点(x,y),Z为这个点横纵坐标的最小公倍数,然后这个点可以往右移动,变成(x+Z,y)或者往上移动(x,y+Z),然后题目给你一个点,问能从哪些点走到这个点。

分析:由题目给我们的点(ex,ey),设其由(x,y)走过来的。先求出x,y的最大公约数a,x=a*b,y=a*c,b,互质,x,y的最小公倍数为abc,所以可以得到新的坐标abc+ab,ac,选取min(ex,ey)中的数等于ac,求出c,进而求出b,当b为整数时说明此时的点满足条件。

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<algorithm>
int Max(int a,int b){
if (a>b)return a;
return b;
}
int Min(int a,int b){
if (a<b)return a;
return b;
}
int YS(int x,int y){
int temp;
while (y){
temp=x%y;
x=y;
y=temp;
}
return x;
}
int sum = 0;
long long cnt=1;
void find_place(int x,int y){
int ys=YS(x,y);
if (x>y){
int b=y/ys;
if (x%(ys*(b+1))==0){
cnt++;
int c=x/(ys*(b+1));
x=Max(ys*b,c*ys);
y=Min(ys*b,c*ys);
find_place(x,y);
}
}
else if(x<y){
int b=x/ys;
if (y%(ys*(b+1))==0){
cnt++;
int c=y/(ys*(b+1));
x=Min(ys*b,ys*c);
y=Max(ys*b,ys*c);
find_place(x,y);
}
}
else {
return ;
}
return ;
}
using namespace std;
int main ()
{
int t;
scanf ("%d",&t);
while (t--){
int x,y;
sum++;
scanf ("%d%d",&x,&y);
cnt=1;
find_place(x,y);
printf ("Case #%d: %lld\n",sum,cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学