您的位置:首页 > 其它

poj 2485 Highways

2016-07-29 17:07 113 查看
Highways

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28289 Accepted: 12882
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible
to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input

The first line of input is an integer T, which tells how many test cases followed. 

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.
Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1

3
0 990 692
990 0 179
692 179 0

Sample Output
692

Hint

Huge input,scanf is recommended.
Source

POJ Contest,Author:Mathematica@ZSU


提示

题意:

岛国flatopia是完全平坦的。不幸的是,flatopia没有高速。所以在flatopia交通并不是很发达。flatopian政府已经意识到这个问题。他们正计划修建一些高速公路,这样就有可能在任何一对城镇之间行驶。

flatopian城镇编号从1到n(3<=n<=500),每一条高速公路连接了两个城镇。所有的公路都是直线的,都是双行道。高速公路可以自由地相互交叉,但一个司机只能在位于两个的城镇之间变道。flatopian政府想要最少总长度且其中一条公路要最长,他们想保证每一个城镇都是连通的,请输出最少总长度中最长的一条公路。

思路:

prim接着求最小生成树,只是变成记录树的最长边。


示例程序

Source Code

Problem: 2485		Code Length: 986B
Memory: 748K		Time: 157MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
#define MAX 1000000007
int map[500][500];
int prim(int n)
{
int d[500],v[500],i,i1,t,max=0,k;
memset(v,0,sizeof(v));
for(i=0;n>i;i++)
{
d[i]=MAX;
}
d[0]=0;
for(i=0;n>i;i++)
{
t=MAX;
for(i1=0;n>i1;i1++)
{
if(v[i1]==0&&t>d[i1])
{
k=i1;
t=d[i1];
}
}
if(max<t)		//记录最小生成树的最长边
{
max=t;
}
v[k]=1;
for(i1=0;n>i1;i1++)
{
if(v[i1]==0&&d[i1]>map[k][i1])
{
d[i1]=map[k][i1];
}
}
}
return max;
}
int main()
{
int t,i,n,i1,i2;
scanf("%d",&t);
for(i=1;t>=i;i++)
{
scanf("%d",&n);
for(i1=0;n>i1;i1++)
{
for(i2=0;n>i2;i2++)
{
scanf("%d",&map[i1][i2]);
}
}
printf("%d\n",prim(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: