您的位置:首页 > 其它

(模板题)poj 1459 Power Network(Edmonds-Karp算法求最大流)

2016-08-01 09:06 393 查看
Power Network

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 26991 Accepted: 14034
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount
0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power
transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of
Con. 



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y.
The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set
ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can
occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second
data set encodes the network from figure 1.
Source

Southeastern Europe 2003


提示

解析来源于书
题意:

有一个电路网络,每个结点可以产生、传递、消耗若干电量,有电线连接节点,每个电线有最大传输量,求这个网络最大的消费量。

思路:

根据题意,从源点到发电站连边,流量为发电量,从用户到汇点连边,流量为消费量,再根据电线连双向边;求最大流即可。(这题的输入比较特殊,新技能get√)


示例程序

Source Code

Problem: 1459		Code Length: 1589B
Memory: 424K		Time: 313MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int map[102][102],p[102];
int bfs(int sn,int ln)
{
int q[8000],i,f=0,top=0;
memset(p,-1,sizeof(p));
p[sn]=0;
q[top]=sn;
top++;
while(f<top)
{
for(i=0;ln>=i;i++)
{
if(p[i]==-1&&map[q[f]][i]>0)
{
p[i]=q[f];
if(i==ln)
{
return 1;
}
q[top]=i;
top++;
}
}
f++;
}
return 0;
}
int maxf(int sn,int ln)
{
int i,max=0,min;
while(bfs(sn,ln)==1)
{
min=1000000007;
for(i=ln;i!=sn;i=p[i])
{
if(min>map[p[i]][i])
{
min=map[p[i]][i];
}
}
for(i=ln;i!=sn;i=p[i])
{
map[p[i]][i]=map[p[i]][i]-min;
map[i][p[i]]=map[i][p[i]]+min;
}
max=max+min;
}
return max;
}
int main()
{
int n,np,nc,m,i,u,v,w;
char ss[30];
while(scanf("%d %d %d %d",&n,&np,&nc,&m)!=EOF)
{
memset(map,0,sizeof(map));
for(i=1;m>=i;i++)
{
scanf("%s",ss);		//这题输入比较特殊,运用了sscanf
sscanf(ss,"(%d,%d)%d",&u,&v,&w);
map[u][v]=w;
}
for(i=1;np>=i;i++)
{
scanf("%s",ss);
sscanf(ss,"(%d)%d",&v,&w);
map
[v]=w;
}
for(i=1;nc>=i;i++)
{
scanf("%s",ss);
sscanf(ss,"(%d)%d",&u,&w);
map[u][n+1]=w;
}
printf("%d\n",maxf(n,n+1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: