您的位置:首页 > 其它

poj 1125 Stockbroker Grapevine

2016-07-29 13:00 267 查看
Stockbroker Grapevine

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33785 Accepted: 18652
Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours
in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.
Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are,
and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring
to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output
3 2
3 10

Source

Southern African 2001


提示

这题我买的书上有参考,以下:

题意:

股票经纪人要在一群人中散步一个传(yao)言(yan),传言只能在认识的人中传递,题目将给出人与人的关系(是否认识),以及传言在某两个认识的人中传递所需的时间,要求程序给出以哪个人为起点,可以在耗时最短的情况下,让所有人收到信息。

思路:

题目要求从某一结点开始,能让消耗的总时间最短。实际上这是一个在有向图中求最短路径问题,先求出每个人向其他人发信息所用的最短时间(当然不是每个人都能向所有人发信息的),然后在所有能向每个人发信息的人中比较他们所用的最大时间,找出所用最大时间最小的那一个所求。这就是简单Floyd算法。


示例程序

Source Code

Problem: 1125 Code Length: 1408B
Memory: 360K Time: 0MS
Language: GCC Result: Accepted
#include <stdio.h>
#define MAX 1000000007
int map[100][100];
void floyd(int n)
{
int i,i1,i2;
for(i=0;n>i;i++)
{
for(i1=0;n>i1;i1++)
{
for(i2=0;n>i2;i2++)
{
if(map[i1][i2]>map[i1][i]+map[i][i2])
{
map[i1][i2]=map[i1][i]+map[i][i2];
}
}
}
}
}
int main()
{
int n,m,v,w,i,i1,max,pos,t;
scanf("%d",&n);
while(n!=0)
{
for(i=0;n>i;i++)
{
for(i1=0;n>i1;i1++)
{
map[i][i1]=MAX;
}
map[i][i]=0;
}
for(i=0;n>i;i++)
{
scanf("%d",&m);
for(i1=1;m>=i1;i1++)
{
scanf("%d %d",&v,&w);
v--;
map[i][v]=w;
}
}
floyd(n);
max=MAX;
for(i=0;n>i;i++)
{
t=0;
for(i1=0;n>i1;i1++) //记录每个人传给另一个人用的最大时间
{
if(map[i][i1]>t)
{
t=map[i][i1];
}
}
if(max>t) //要求的最短耗时的最大时间(边)
{
max=t;
pos=i+1;
}
}
if(max!=MAX)
{
printf("%d %d\n",pos,max);
}
else //没有连通
{
printf("disjoint\n");
}
scanf("%d",&n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: