您的位置:首页 > 大数据 > 人工智能

HDU:1702 ACboy needs your help again!(简单栈、队列)

2016-07-25 23:47 501 查看


ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5669 Accepted Submission(s): 2962



Problem Description

ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT


Sample Output

1
2
2
1
1
2
None
2
3


Source

2007省赛集训队练习赛(1)

Recommend

lcy

题目大意:给你数据的方式,队列或栈,IN入栈或入队,OUT输出top或front。

解题思路:直接STL写。

代码如下:

#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
using namespace std;
int main()
{
int t;
int order;
char lei[10];
char CMD[5];
scanf("%d",&t);
for(int j=0;j<t;j++)
{
scanf("%d %s",&order,lei);
if(lei[2]=='F')
{
queue<int>que;
int shu;
for(int i=0;i<order;i++)
{
scanf("%s",CMD);
if(CMD[0]=='I')
{
scanf("%d",&shu);
que.push(shu);
}
else
{
if(!que.empty())
{
printf("%d\n",que.front());
que.pop();
}
else
{
printf("None\n");
}
}
}
while(!que.empty())
{
que.pop();
}
}
else
{
stack<int>zhan;
int shu;
for(int i=0;i<order;i++)
{
memset(lei,0,sizeof(CMD));
getchar();
scanf("%s",CMD);
if(CMD[0]=='I')
{
scanf("%d",&shu);
zhan.push(shu);
}
else
{
if(!zhan.empty())
{
printf("%d\n",zhan.top());
zhan.pop();
}
else
{
printf("None\n");
}
}
}
while(!zhan.empty())
{
zhan.pop();
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  队列