您的位置:首页 > 其它

HDU:1896 Stones(优先队列)

2016-07-26 00:12 302 查看


Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 2044    Accepted Submission(s): 1345


Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 

There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell
me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 

For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position
of the i-th stone and how far Sempr can throw it.

 

Output

Just output one line for one test case, as described in the Description.

 

Sample Input

2
2
1 5
2 4
2
1 5
6 6

 

Sample Output

11
12

 

Author

Sempr|CrazyBird|hust07p43

 

Source

HDU 2008-4 Programming Contest

 

Recommend

lcy

题目大意:一个人从东往西走,路上有石头,碰到第奇数个石头往前扔一下,碰到第偶数个石头则忽略,问所扔石头的最远距离距这个人的出发点的距离为多少。

解题思路:优先队列。(注意当多个石头扎堆在一个地方时,先扔那个扔的最近的那个石头,然后继续在这个点扔奇数的石头,直到扔完这个点的石头,才继续向前走)

代码如下:
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
using namespace std;
struct node
{
int pos,dis;
friend bool operator<(node x,node y)
{
if(x.pos==y.pos)//位置一样时,按照抛的距离从小到大排序
return x.dis>y.dis;
else
return x.pos>y.pos;
}
};
int main()
{
int t;
struct node tmp;
scanf("%d",&t);
while(t--)
{
priority_queue<node>q;
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d%d",&tmp.pos,&tmp.dis);
q.push(tmp);
}
int flag=1;//控制奇偶
while(!q.empty())
{
tmp=q.top();
q.pop();//偶数的话就不再加入队列了。。。
if(flag&1)
{
tmp.pos=tmp.pos+tmp.dis;
q.push(tmp);//扔过之后记得将扔过的石头加入队列
}
flag++;
}
printf("%d\n",tmp.pos);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  优先队列