您的位置:首页 > 其它

C - Ekka Dokka

2016-07-24 22:48 316 查看

C - Ekka Dokka

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu

Submit

Status

Description

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that’s why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print “Impossible” if they can’t buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

FAQ | About Virtual Judge | Forum | Discuss | Open Source Project

All Copyright Reserved ©2010-2014 HUST ACM/ICPC TEAM

Anything about the OJ, please ask in the forum, or contact author:Isun

Server Time:

题意:给定数w,使w=m*n,m为偶数,n为奇数。不存在输出“Impossible”,存在多组输出最小的m.

思路:奇数*偶数=偶数;w为奇数不存在;为偶数使w/2,循环直到w为奇数。

失误:我就想说这道题有问题,为什么用__int64不行,让我以为一直除二都有错。还要用用个for循环从2开始除???

代码如下:

#include<cstdio>

int main()
{
long long  t,w,k=0,i,n,m,flag;//用__int64就是不行
scanf("%lld",&t);

while(t--)
{
scanf("%lld",&w);

++k;
if(w&1)
printf("Case %lld: Impossible\n",k);

else
{
m=1;
while(w%2==0)//用一个for循环对[2,w]的所有偶数判断也行
{
w/=2;
m*=2;
}

printf("Case %lld: %lld %lld\n",k,w,m);

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: