您的位置:首页 > 其它

E - Crossed Ladders

2016-07-26 16:17 92 查看

E - Crossed Ladders

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu

Submit

Status

Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each test case contains three positive floating point numbers giving the values of x, y, and c.

Output

For each case, output the case number and the width of the street in feet. Errors less than 10-6 will be ignored.

Sample Input

4

30 40 10

12.619429 8.163332 3

10 10 3

10 10 1

Sample Output

Case 1: 26.0328775442

Case 2: 6.99999923

Case 3: 8

Case 4: 9.797958971

题意:

思路:

失误:

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;

#define esp 1e-13
double x,y,c,l,r,mid;
double judge(double mid)
{
return  (sqrt(x*x-mid*mid)*sqrt(y*y-mid*mid))/(sqrt(y*y-mid*mid)+sqrt(x*x-mid*mid )); //写错了好几次 ,成写成加
}
int main()
{
int t,k=0;
cin>>t;
while(t--)
{
cin>>x>>y>>c;
l=0;r=max(x,y);
while(r-l>esp)
{
mid=(l+r)/2.0;
if(abs(judge(mid)-c)<esp)  break;
if(judge(mid)>c)
{
l=mid-esp;
}
else
{
r=mid+esp;
}
}

cout<<"Case "<<++k<<": ";
printf("%.6lf\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: