您的位置:首页 > 其它

HDU 5477 A Sweet Journey

2016-07-24 17:20 363 查看

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 800    Accepted Submission(s): 423

[align=left]Problem Description[/align]
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per
meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)



 

[align=left]Input[/align]
In the first line there is an integer t (1≤t≤50),
indicating the number of test cases.

For each test case:

The first line contains four integers, n, A, B, L.

Next n lines, each line contains two integers: Li,Ri,
which represents the interval [Li,Ri]
is swamp.
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L.

Make sure intervals are not overlapped which means
Ri<Li+1
for each i (1≤i<n).

Others are all flats except the swamps.

 
[align=left]Output[/align]
For each text case:

Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.

 
[align=left]Sample Input[/align]

1
2 2 2 5
1 2
3 4

 
[align=left]Sample Output[/align]

Case #1: 0题意:一个人想去旅游,问他一开始最小需要的体力是多少。有两种地形,沼泽和平原,如果是沼泽的话,每米消耗A的体力,在平原每米恢复B的体力。要注意的一点是在这个过程中这个人的最小体力值为0,不可以小于0;利用这个条件求出在开始时具有的最小体力值。 思路:最小值更新的问题;代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
int n,a,b,l,t;
int x,y;
int k=1;
scanf("%d",&t);
while(t--)
{
int sum=0,minn=100000,end=0;//end用来记录上一个沼泽结束的位置
scanf("%d%d%d%d",&n,&a,&b,&l);
while(n--)
{
scanf("%d%d",&x,&y);
sum=sum+(x-end)*b-(y-x)*a;//累加体力
minn=min(sum,minn);//更新minn,求过程中的最小体力.
end=y; //更新end
}
printf("Case #%d: ",k++);
if(minn<0)
printf("%d\n",-minn);
else
printf("0\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: