您的位置:首页 > 其它

HDOJ 1896 Stones(优先队列)

2016-07-25 19:32 369 查看
Stones
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Submit Status

Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 

There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell
me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 

For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position
of the i-th stone and how far Sempr can throw it. 

 

Output

Just output one line for one test case, as described in the Description. 

 

Sample Input

2
2
1 5
2 4
2
1 5
6 6

 

Sample Output

11
12
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
int num,dis,pos;
bool friend operator<(node x,node y)
{
if(x.pos==y.pos)
return x.dis>y.dis;//若位置相同优先取扔的距离小的
else
return x.pos>y.pos;//否则优先取位置小的,即靠前的;
}
}a;
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
priority_queue<node>q;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a.pos,&a.dis);
q.push(a);
}
int time=0,max=0;//time记录遇到的石头的个数;
//max记录最大位置
while(!q.empty())
{
a=q.top();
q.pop();
time++;
if(time&1)
{
a.pos+=a.dis;
if(a.pos>max)
max=a.pos;
q.push(a);
}
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: