您的位置:首页 > 大数据 > 人工智能

HDU(1789)Doing Homework again(贪心,找出损失最少分)

2016-07-22 17:14 411 查看

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11306    Accepted Submission(s): 6636


[align=left]Problem Description[/align]
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the
deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

 

[align=left]Output[/align]
For each test case, you should output the smallest total reduced score, one line per test case.

 

[align=left]Sample Input[/align]

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

 

[align=left]Sample Output[/align]

0
3
5
题目大意:
给出n道题,并给出每道题完成的限制时间,以及不完成所损失的分数,每天只能完成一道,学生如何做才能使损失的
分数最少。
解法,用结构体把每题的限制时间以及损失的分数,然后按分数大小排序,在从最大分数的限制往前搜,并将用过的
天数标记;
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct none
{
int x,y;
}no[10000];
bool cmp(none a, none b)
{
return a.y>b.y;
}

int main ()
{
int t,n;
scanf("%d", &t);
while(t--)
{
int i, j, sum=0;
int a[1001];
memset(a,0,sizeof(a));
int k=0;
scanf("%d", &n);
for(i=0; i<n; i++)
scanf("%d", &no[i].x);
for(i=0; i<n; i++)
scanf("%d", &no[i].y);
sort(no,no+n,cmp);
for(i=0; i<n; i++)
{k=0;
for(j=no[i].x; j>0; j--)
{
if(a[j]==0)
{
a[j]=1;
k++;
break;
}
}
if(k==0)
sum+=no[i].y;
}
printf("%d\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: