您的位置:首页 > 产品设计 > UI/UE

文章标题POJ 2785:4 Values whose Sum is 0?(二分)

2016-07-22 08:44 483 查看

4 Values whose Sum is 0

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6

-45 22 42 -16

-41 -27 56 30

-36 53 -37 77

-36 30 -75 -46

26 -38 -10 62

-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意:题目要我们从四个表中各找一个数相加的和为0。

分析:直接暴力破解肯定不行,可先对四个数表分成两组进行枚举相加,然后其中一个枚举,另一个二分,记住,记录重复的情况。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<math.h>
#include<algorithm>
using namespace std;
int a[4005],b[4005],c[4005],d[4005];
int sum1[4005*4005],sum2[4005*4005];
int bs (int a[],int key,int k){
int lo=0,hi=k-1;
int mi,ans=hi+1;
while (lo<=hi){
mi=((hi-lo)>>1)+lo;
//if (a[mi]==key)return mi;
if (a[mi]<key)lo=mi+1;
else {
hi=mi-1;ans=min(ans,mi);
}
}
if (ans==hi+1)
return -1;
return ans;
}
int main ()
{
int n;
while (scanf ("%d",&n)!=EOF){
for (int i=0;i<n;i++){
scanf ("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
}
int k1=0;
for (int i=0;i<n;i++){
for (int j=0;j<n;j++){
sum1[k1++]=a[i]+b[j];
}
}
int k2=0;
for (int i=0;i<n;i++){
for (int j=0;j<n;j++){
sum2[k2++]=c[i]+d[j];
}
}
sort (sum1,sum1+k1);
int count=0;
for (int i=0;i<k2;i++){
count+=upper_bound(sum1,sum1+k1,-sum2[i])-lower_bound(sum1,sum1+k1,-sum2[i]);//点睛之笔
}
printf ("%d\n",count);
}
return 0;
}


其中有一个点睛之笔

count+=upper_bound(sum1,sum1+k1,-sum2[i])-lower_bound(sum1,sum1+k1,-sum2[i]);//点睛之笔

这是借鉴别人的成果,通过运用这个,可以减少很多不必要的操作。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二分