您的位置:首页 > 编程语言 > C语言/C++

PAT 1057 Stack (30)

2013-04-15 19:45 597 查看



http://pat.zju.edu.cn/contests/pat-a-practise/1057


1057. Stack (30)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement
a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:
Push key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.
Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目大意: 有一个栈,给三种操作 Push X,Pop ,PeekMedian。PeekMedian是返回栈里面所有数的中位数。

思路:树状数组+二分, 模拟栈,然后对数字出现次数改变树状数组,然后PeekMedian的时候二分和。

#include<cstdio>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
#include<deque>
#include<map>
#include<algorithm>
#include<string>
#include<cmath>
#include<cstring>
using namespace std;
#define MAXN 100005
class BITree
{
public:
static const int offset=10;
int u[MAXN];
void clear()
{
memset(u,0,sizeof(u));
}
void modify(int x,int v)
{
for(x+=offset; x<MAXN; x+=x&-x) u[x]+=v;
}
int getSum(int x)
{
int s=0;
for(x+=offset; x; x-=x&-x) s+=u[x];
return s;
}
};
BITree tree;

int BinFind(int l,int r,int k)
{
if(l==r)
return l;
int mid=(l+r)/2;
if(tree.getSum(mid)<k)
return BinFind(mid+1,r,k);
else
return BinFind(l,mid,k);
}
int main()
{
tree.clear();
int n;
stack<int> st;
scanf("%d",&n);
char tmp[10];
for(int i=0;i<n;i++)
{
scanf("%s",tmp);
if(strcmp(tmp,"Pop")==0)
{
if(st.size())
{
tree.modify(st.top(),-1);
printf("%d\n",st.top());
st.pop();
}
else
{
printf("Invalid\n");
}
}
else if(strcmp(tmp,"Push")==0)
{
int t;
scanf("%d",&t);
st.push(t);
tree.modify(st.top(),1);
}
el
4000
se
{
if(st.size())
{
int res=0;
res=BinFind(1,100005,(st.size()+1)/2);
printf("%d\n",res);
}
else
printf("Invalid\n");
}
}
return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT 树状数组 二分