您的位置:首页 > 其它

Hotel

2016-07-21 20:22 246 查看
Hotel
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

Last year summer Max traveled to California for his vacation. He had a great time there: took many photos, visited famous universities, enjoyed beautiful beaches and tasted various delicious foods. It is such a good trip that Max plans to travel there one more time this year. Max is satisfied with the accommodation of the hotel he booked last year but he lost the card of that hotel and can not remember quite clearly what its name is. So Max searched
in the web for the information of hotels in California ans got piles of choice. Could you help Max pick out those that might be the right hotel?

Input

Input may consist of several test data sets. For each data set, it can be format as below: For the first line, there is one string consisting of '*','?'and 'a'-'z'characters.This string represents the hotel name that Max can remember.The '*'and '?'is wildcard characters. '*' matches zero or more lowercase character (s),and '?'matches only one lowercase character.

In the next line there is one integer n(1<=n<=300)representing the number of hotel Max found ,and then n lines follow.Each line contains one string of lowercase character(s),the name of the hotel.
The length of every string doesn't exceed 50.

Output

For each test set. just simply one integer in a line telling the number of hotel in the list whose matches the one Max remembered.

Sample Input

herbert
2
amazon
herbert

?ert*
2
amazon
herbert

*
2
amazon
anything

herbert?
2
amazon
herber

Sample Output

1
0
2
0

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
using namespace std;
bool pipei(string a,string b){
for(int i=0;i<a.length();i++){
if(a[i]=='*'){
if(i==a.length()-1) return true;
string c= a.substr(i+1);
for(int j=i;j<b.length();j++){
if(pipei(c,b.substr(j))) return true;
}
}else{

if(i>=b.length()) return false;if(a[i]=='?') continue;
if(a[i]!=b[i]) return false;

}
}
return true;
}
int main(){
string a,b;
while(cin>>a){
int n;
int ans=0;
scanf("%d",&n);
for(int i=0;i<n;i++){
cin>>b;
if(pipei(a,b)){
ans++;
}
}
printf("%d\n",ans);
}
return 0;
}


View Code
递归函数。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: