您的位置:首页 > 大数据 > 人工智能

POJ 1995 Raising Modulo Numbers(快速幂)

2016-07-21 14:58 507 查看
Raising Modulo Numbers

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment
was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players
including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 
(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input
3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output
2
13195
13

题目大意:给出两个数组a和b,一个数m,求(a1 ^ b1 + a2 ^ b2 + …… + an ^ bn) % m的值。
解题思路:利用快速幂以及模运算的性质(a + b) % m = (a % m + b % m) % m

代码如下:

#include <cstdio>

typedef long long ll;

const int maxn = 45005;

typedef struct{
int a;
int b;
}num;
num h[maxn];

ll mod_pow(ll x,ll n,ll mod)
{
if(n == 0)
return 1;
ll res = mod_pow(x * x % mod,n / 2,mod);
if(n & 1)
res = res * x % mod;
return res;
}

int main()
{
int z,m,n;
ll ans;
scanf("%d",&z);
while(z--){
scanf("%d",&m);
scanf("%d",&n);
ans = 0;
for(int i = 0;i < n;i++){
scanf("%d %d",&h[i].a,&h[i].b);
}
for(int i = 0;i < n;i++){
ans += mod_pow(h[i].a,h[i].b,m) % m;
}
printf("%lld\n",ans % m);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ