您的位置:首页 > 其它

POJ 2366 Sacrament of the sum

2016-07-20 21:37 351 查看
Sacrament of the sum

Description

— The Brother of mine, the Head of Monastic Order wants to know tomorrow about the results long-term researches. He wants to see neither more nor less than the Summering Machine! Even moreover, he wants our Machine — only a machine — to demonstrate its comprehension
of the Sacrament of the Sum as deeply as it is possible. He wants our Machine to find two numbers that give the sum equal to the Sacred Number 10 000. 

— Tsh-sh-sh! This is madness that borders on blasphemy! How can the Machine calculate the Sacred Number? Twenty seven years we work on it, but we've could teach it to tell if the sum of two introduced numbers greater or lower than 10 000. Can an ordinary mortal
find two numbers that there sum will be equal to 10 000? 

— But we'll have to do it with the help of our Machine, even if it is not capable. Otherwise we'll have... let's say, big problems, if it is possible to call boiling oil like this. However, I have an idea. Do you remember, last week we've entered two numbers
-7 and 13 into the Machine, and it answered that their sum is lower than 10 000. I don't know how to check this, but nothing's left for us than to believe to the fruit of our work. Let's enter now a greater number than -7 and start up the Machine again. We'll
do like this again and again until we find a number that being added to 13 will give us 10 000. The only thing we are to do is to prepare an ascending list of numbers. 

— I don't believe in this... Let's start with the sum that is obviously greater than the Sacred Number and we'll decrease one of the summand. So we have more chances to avoid boilin... big problems. 

Haven't come to an agreement, the Brothers went away to their cells. By next day everyone of them has prepared a list of numbers that, to his opinion, could save them... Can both of the lists save them together? 

Your program should decide, if it is possible to choose from two lists of integers such two numbers that their sum would be equal to 10 000.
Input

You are given both of these lists one by one. Format of each of these lists is as follows: in the first line of the list the quantity of numbers Ni of the i-th list is written. Further there is an i-th list of numbers each number in its line (Ni lines).The
following conditions are satisfied: 1 <= Ni <= 50 000, each element of the lists lays in the range from -32768 to 32767. The first list is ascending and the second one is descending.
Output

You should write "YES" to the standard output if it is possible to choose from the two lists of integers such two numbers that their sum would be equal to 10 000. Otherwise you should write "NO".
Sample Input
4
-175
19
19
10424
3
8951
-424
-788

Sample Output
YES

题目大意:给出两组数字,第一组按非降序排列,第二组按非升序排列,问是否有两个数的和等于10000。
解题思路:从两个数组的第一个元素开始遍历,如果相加大于10000,则访问第二组的下一个元素;若相加小于10000,则访问第一组的下一个元素。

代码如下:

#include <cstdio>
#include <algorithm>

using namespace std;
const int maxn = 50005;

int a[maxn],b[maxn];
int N[3];
int main()
{
int i,j,k;
bool flag = false;
scanf("%d",&N[1]);
for(i = 0;i < N[1];i++){
scanf("%d",&a[i]);
}
scanf("%d",&N[2]);
for(i = 0;i < N[2];i++){
scanf("%d",&b[i]);
}
for(i = 0,j = 0;i < N[1] && j < N[2];){
if(a[i] + b[j] > 10000)
j++;
else if(a[i] + b[j] < 10000)
i++;
else{
//flag = true;
break;
}

}
if(i >= N[1] || j >= N[2])
printf("NO\n");
else
printf("YES\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ