您的位置:首页 > 其它

PAT甲级练习题A1001.A+B Format

2016-07-12 22:12 302 查看

题目描述

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

题目解析

这题并不难,和甲级的第一题难度差不多,看懂英文就OK了。

代码

#include<iostream>
#include<string>
using namespace std;

int main()
{
int a, b, c, d;
string out;
cin >> a >> b;
c = a + b;
if (c < 0)
d = -c;
else
d = c;
int i = 1;
do
{
char ch = '0' + d % 10;
out = ch + out;
d /= 10;
if (i % 3 == 0 && d)
out = "," + out;
++i;
} while (d);
if (c < 0)
out = "-" + out;
cout << out << endl;
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: