您的位置:首页 > 其它

Balanced Lineup(线段树——根据区间找最值)

2016-07-09 23:40 274 查看

Balanced Lineup

Time Limit: 5000ms
Memory Limit: 65536KB
64-bit integer IO format: %lld      Java class name:
Main

Submit

Status
PID: 3383

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤
height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and
Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow
i

Lines N+2..N+Q+1: Two integers A and B (1 ≤
A ≤ B ≤ N), representing the range of cows from A to
B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0


   query()函数

#include <stdio.h>
#include <algorithm>
#define MAX 50000
using namespace std;
int a[MAX+10];
int low, hei;
struct node{
int mx, mn;
}seg[MAX*4+10];

void build(int node, int l, int r)
{
if(l == r){
seg[node].mn = seg[node].mx = a[l];
return;
}
int m = (l + r) / 2;
build(node * 2, l, m);
build(node * 2 + 1, m + 1, r);
seg[node].mn = seg[node*2].mn < seg[node*2+1].mn ? seg[node*2].mn : seg[node*2+1].mn;
seg[node].mx = seg[node*2].mx > seg[node*2+1].mx ? seg[node*2].mx : seg[node*2+1].mx;
}

void query (int node, int l, int r, int s, int e)
{
if (l == s && r == e)
{
low = min (low, seg[node].mn);
hei = max (hei, seg[node].mx);
return ;
}
int m = (l + r) / 2;
if (e <= m)
query (2 * node, l, m, s, e);
else if (s >= m + 1)
query (2 * node + 1, m + 1, r, s, e);
else
{
query(node * 2, l, m, s, m);
query (2 * node + 1, m + 1, r, m + 1, e);
}
}

int main()
{
int n, m;
scanf("%d %d", &n, &m);
for(int i = 1; i <= n; i ++ ){
scanf("%d", &a[i]);
}
build(1, 1, n);
while(m -- ){
int a, b;
scanf("%d %d", &a, &b);
low = 1000001;
hei = 0;
query(1, 1, n, a, b);
printf("%d\n", hei - low);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: