您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence

2016-06-03 17:55 447 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1711

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 19827    Accepted Submission(s): 8511

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2],
...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains
N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

Source

HDU 2007-Spring Programming Contest

Recommend

lcy

思路:KMP算法的应用。直接上模板就可以了。

附上AC代码:

#include <bits/stdc++.h>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
const int maxn = 1000005;
const int maxm = 10005;
int t[maxn], p[maxm], f[maxm];
int n, m;

void get_fail(){
f[0] = f[1] = 0;
for (int i=1; i<m; ++i){
int j = f[i];
while (j && p[i]!=p[j])
j = f[j];
f[i+1] = p[i]==p[j] ? j+1 : 0;
}
}

int kmp(){
get_fail();
int j = 0;
for (int i=0; i<n; ++i){
while (j && p[j]!=t[i])
j = f[j];
if (p[j] == t[i])
++j;
if (j == m)
return i-m+2;
}
return -1;
}

int main(){
#ifdef LOCAL
freopen("input.txt", "r", stdin);
freopen("output.txt", "w", stdout);
#endif
int T;
scanf("%d", &T);
while (T--){
scanf("%d%d", &n, &m);
for (int i=0; i<n; ++i)
scanf("%d", t+i);
for (int i=0; i<m; ++i)
scanf("%d", p+i);
printf("%d\n", kmp());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu KMP算法