您的位置:首页 > 产品设计 > UI/UE

HDU 1005 Number Sequence

2016-06-06 19:13 309 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1005

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 149540    Accepted Submission(s): 36405

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case
is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

Author

CHEN, Shunbao

Source

ZJCPC2004

Recommend

JGShining

思路:数据太大,明显不可能直接递推。结果模7,显然必有循环节,找到循环节,利用循环节输出答案。注意:循环节不一定是从最初的开始循环。

附上AC代码:

#include <bits/stdc++.h>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
const int maxn = 55;
const int mod = 7;
int f[maxn];
int a, b, n;

int main(){
#ifdef LOCAL
freopen("input.txt", "r", stdin);
freopen("output.txt", "w", stdout);
#endif
f[1] = f[2] = 1;
while (~scanf("%d%d%d", &a, &b, &n) && a+b+n){
int i, j, k;
for (i=3; i<maxn; ++i){
f[i] = (a*f[i-1]+b*f[i-2])%mod;
for (j=i-2; j>1; --j)
if (f[j]==f[i] && f[j-1]==f[i-1])
break;
if (j > 1)
break;
}
k = i-j;
if (n > j)
n = (n-j)%k+j;
printf("%d\n", f
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 递推 循环节