您的位置:首页 > 其它

HDU 1003 Max Sum (O(N) 算法)

2016-05-25 14:45 288 查看

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 210088    Accepted Submission(s): 49285


[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6

大体题意:
给你n 个元素的数组,求出一个连续子序列 使得子序列的和最大,并且输出 子序列的起始位置和终止位置!

思路:
直接遍历数组,thissum += a[i],当比maxsum 大时,更新maxsum 并且更新左位置和右位置
如果thissum < 0肯定不能作为起点,也不是最优的直接把thissum初始化为0,然后更新左位置!
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100000 + 10;
int a[maxn];
int l,r,n,k;
int solve(){
l = r = k = 1;
int maxsum = -maxn,thissum = 0;
for (int i = 1; i <= n; ++i){
thissum += a[i];
if (thissum > maxsum)maxsum = thissum,r=i,l=k;
if (thissum < 0)thissum = 0,k=i+1;
}
return maxsum;
}
int main(){
int T,cnt=0;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
for (int i = 1; i <= n; ++i){
scanf("%d",&a[i]);
}
int ans = solve();
if (cnt)printf("\n");
printf("Case %d:\n",++cnt);
printf("%d %d %d\n",ans,l,r);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: