您的位置:首页 > 其它

POJ 1922 Ride to School (贪心)

2016-05-20 09:34 411 查看
Ride to School

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 20806 Accepted: 8399

Description

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose
to ride a bike.

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he
will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider
he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4

20 0

25 -155

27 190

30 240

2

21 0

22 34

0

Sample Output

780

771

题意:Charley想从wanliu到yanyuan,但是Charley喜欢跟随着速度快的一起走,如果没有遇到,就等,如果遇到就按照快的速度一起走,问到yanyuan的最短时间

此时可以看作寻找其他人里面用时最少的一个,如果有人刚开始hi的时间为负则不用考虑,,在Charley的前面,Charley追不上,只能选在Charley后面的用时最少的

一个,但最终的得到的时间是个浮点数,则需要用ceil(函数进行向上取整)。

代码:

#include <stdio.h>
#include <stdlib.h>
#include <math.h>

int main()
{
int n, v, t;
double time, min;
while(1)
{
scanf("%d", &n);
if (n == 0) break;
min = 4.5 * 3600;///或者取最大的 min=999999999;

while(n--)
{
scanf("%d%d", &v, &t);
if (t < 0) continue;
time = 4.5 / v * 3600 + t;///到达中间yanyuan 的时间
if (time <= min)  ///查找哪个用时最少的
{
min = time;
}
}
int t = ceil(min);///向上取整函数(头文件math,例如74.12->75、-74.12——>74).
printf("%d\n", t);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: