您的位置:首页 > 其它

POJ 1611 The Suspects

2016-05-26 16:03 369 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K

Total Submissions: 31255 Accepted: 15187

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4

2 1 2

5 10 13 11 12 14

2 0 1

2 99 2

200 2

1 5

5 1 2 3 4 5

1 0

0 0

Sample Output

4

1

1

题解:

有一个学校,有N个学生,编号为0-N-1,现在0号学生感染了非典,凡是和0在一个社团的人就会感染,并且这些人如果还参加了别的社团,他所在的社团照样全部感染,求感染的人数。

解题思路:

并查集的变种,实质就是求0所在的强连通图的结点数目。
代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>

using namespace std;
const int maxx=30005;
int par[maxx];
int ren[maxx];
int n,m;
void init()
{
for(int i=0;i<n;i++)
{
par[i]=i;
ren[i]=1;
}

}
int find(int x)
{
if(par[x]==x)
return x;
else
return par[x]=find(par[x]);
}
void unite(int x,int y)
{
x=find(x);
y=find(y);
if(x!=y)
{
if(ren[x]>ren[y])
{
par[y]=x;
ren[x]+=ren[y]; ///合并集合的数目
}
else
{
par[x]=y;
ren[y]+=ren[x];///合并集合的数目
}

}
else
return ;
}

int main()
{
while(~scanf("%d%d",&n,&m))
{
if(n+m==0)
break;
init();
for(int i=0;i<m;i++)///多少组
{
int x;
scanf("%d",&x);///一组多少个数
int a,b;
scanf("%d",&a);///其他均为第一个相连
for(int j=1;j<x;j++)
{
scanf("%d",&b);//其后的数
unite(a,b);///合并
}
}
printf("%d\n",ren[find(0)]); ///寻找find(0)处的集合个数
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: