您的位置:首页 > 编程语言 > Go语言

POJ 3635 Dragon Balls (并查集)

2016-05-27 21:45 411 查看
Dragon Balls

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5373 Accepted Submission(s): 2028

Problem Description

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical
strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the
ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100).

For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).

Each of the following Q lines contains either a fact or a question as the follow format:

T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.

Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2

3 3

T 1 2

T 3 2

Q 2

3 4

T 1 2

Q 1

T 1 3

Q 1

Sample Output

Case 1:

2 3 0

Case 2:

2 2 1
3 3 2

题意:

悟空在寻找龙珠,一共有n个龙珠,m条操作。操作有两种。

T a b 表示把a龙珠所在的城里的所有龙珠运到b所在的城里

Q a 表示对a的询问,要求输出 a所在的城, a所在的城里一共有多少个龙珠, a经过几次到达现在所在的城的。(移动的次数)

分析:定义par同并查集的一般操作,mov表示经过几步到达现在所在的城,num表示该城里的龙珠数。

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;
const int maxx=10010;
int par[maxx];///存放根节点
int num[maxx];///存放根节点下的元素数目
int mov[maxx];///存放移动的次数
int n,m;
void init()
{
for(int i=0; i<=n; i++)
{
par[i]=i;//初始化
num[i]=1;
mov[i]=0;
}
}

int find(int x)
{
if(par[x]==x)
return x;
int temp=par[x];
par[x]=find(par[x]);
mov[x]+=mov[temp];///更新移动的次数(加每个根节点的移动次数)
return par[x];
}

void unite(int x,int y)
{
int a=find(x);
int b=find(y);
if(a!=b)
{
par[a]=b;
num[b]+=num[a];///更新每个城市的数目
mov[a]=1;///此时结点合并左结点移动次数加1
}
}

int main()
{
int t;

int cas=0;
scanf("%d",&t);
getchar();
while(t--)
{
scanf("%d%d",&n,&m);
getchar();
init();
printf("Case %d:\n",++cas);
char s[5];
for(int i=1; i<=m; i++)
{
scanf("%s",s);
if(s[0]=='T')
{
int a,b;
scanf("%d%d",&a,&b);
unite(a,b);///合并
}
else
{
int x;
scanf("%d",&x);
int y=find(x);///所在的城市、以及城市内的龙珠个数
printf("%d %d %d\n",y,num[y],mov[x]);
}
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: