您的位置:首页 > 其它

zoj-3869-Ace of Aces

2016-05-08 20:34 309 查看
Description

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of “Ace of Aces”.

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the “Ace of Aces”. If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the “Ace of Aces”.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with “Ace of Aces”. If no one win the election, output “Nobody” (without quotes) instead.

Sample Input

3

5

2 2 2 1 1

5

1 1 2 2 3

1

998

Sample Output

2

Nobody

998

求最多选举票的那个人,如果同票或者没有,输出Nobody

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
int b[1005];
memset(b,0,sizeof(b));
int w=0,val=0,cnt;
int x;
for(int i=0;i<n;i++) { scanf("%d",&x); b[x]++; }
//printf("%d\n",b[998]);
for(int i=0;i<1001;i++)
{
if(b[i]>w)
{
w=b[i];
cnt=i;
val=1;
}
else if(b[i]==w) val=0;
}
if(val==1) printf("%d\n",cnt);
else printf("Nobody\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: