您的位置:首页 > 其它

HDU 2577 How to Type

2016-04-21 18:53 281 查看
http://vjudge.net/contest/view.action?cid=50286#problem/KK - How to TypeTime Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64uSubmit Status Practice HDU 2577DescriptionPirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string. InputThe first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100. OutputFor each test case, you must output the smallest times of typing the key to finish typing this string. Sample Input
 3
Pirates
HDUacm
HDUACM  Sample Output
 8
8
8 Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
题目大意:输入一段字符串。求打出这段字符串所按的最少键数。解题思路:(注意这一点就能ac,按capslock后再按shift大写变小写,)模拟一下就可以了
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<stdlib.h>
#include<iomanip>
#include<list>
#include<deque>
#include<map>
#include <stdio.h>
#include <queue>

#define maxn 10000+5
#define ull unsigned long long
#define ll long long
#define reP(i,n) for(i=1;i<=n;i++)
#define rep(i,n) for(i=0;i<n;i++)
#define cle(a) memset(a,0,sizeof(a))
#define mod 90001
#define PI 3.141592657

const ull inf = 1LL << 61;
const double eps=1e-5;

using namespace std;

bool cmp(int a,int b){
return a>b;
}
char s[110];
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int t;
bool caps;
cin>>t;
while(t--)
{
cin>>s;
int ans=0;
caps=false;
for(int i=0;i<strlen(s);i++)
{
if(s[i]>='A'&&s[i]<='Z')
{
if(caps==false)ans++;///shif
if(s[i+1]<='Z'&&s[i+1]>='A')
caps=true;
ans++;
}
else
{
if(caps)
ans++;///shif
if((s[i+1]>='a'&&s[i+1]<='z')||s[i+1]=='\0')
caps=false;
ans++;
}
}
if(caps)
ans++;
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: