您的位置:首页 > 其它

杭电5665 Lucky

2016-04-18 17:27 387 查看


Lucky

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 328    Accepted Submission(s): 211


Problem Description

    Chaos
August likes to study the lucky numbers.

    For
a set of numbers S,we set the minimum non-negative integer,which can't be gotten by adding the number in S,as the lucky number.Of course,each number can be used many times.

    Now,
given a set of number S, you should answer whether S has a lucky number."NO" should be outputted only when it does have a lucky number.Otherwise,output "YES".

 

Input

    The
first line is a number T,which is case number.

    In
each case,the first line is a number n,which is the size of the number set.

    Next
are n numbers,means the number in the number set.

    1≤n≤105,1≤T≤10,0≤ai≤109.

 

Output

    Output“YES”or
“NO”to every query.

 

Sample Input

1
1
2

 

Sample Output

NO

 

Source

BestCoder Round #80

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  5669 5668 5667 5666 5664 

 
0也是自然数,0也是自然数,0也是自然数:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int i,j,k,l,m,n;
int main()
{
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
int flag=0;
int cnt=0;
for(i=0;i<m;i++)
{
scanf("%d",&k);
if(k==1)
flag=1;
if(k==0)
cnt=1;
}
if(flag&cnt)
printf("YES\n");
else
printf("NO\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 简单题