您的位置:首页 > 其它

poj2409 Let it Bead(polyal原理)

2016-04-26 17:46 411 查看
Let it Bead

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5367 Accepted: 3587
Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent
of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one
color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced. 

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate
the number of different bracelets that can be made.
Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine,
cs<=32, i.e. their product does not exceed 32.
Output


For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.
Sample Input
1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output
1
2
3
5
8
13
21
问,一串由n个珠子组成的项链,用c种颜色涂染,问能形成多少种不同项链,由旋转而得到的为同一种,反转而来的也为同一种。
polyal原理:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int m,n,j,k,l,i,p;
int gcd(int a,int b)
{
if(b==0)
return a;
return gcd(b,a%b);
}
void polyal()
{
int i,c,s=0,t;
for(i=0;i<n;i++)
{
c=gcd(n,i);
s+=(int)pow((double)m,(double)c);
}
if(n&1)
{
c=(n+1)/2;
t=(int)pow((double)m,(double)c);
s+=t*n;
}
else
{
c=n/2;
t=(int)pow((double)m,(double)c);
s+=(n/2)*t;
t*=m;
s+=(n/2)*t;
}
printf("%d\n",s/(2*n));
}
int main()
{
while(scanf("%d%d",&m,&n),m+n)
{
polyal();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj polyal原理