您的位置:首页 > 其它

HDU 1008 Elevator(模拟题)

2016-04-14 13:42 323 查看

Elevator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 61055 Accepted Submission(s): 33506



[align=left]Problem Description[/align]
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds
to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

[align=left]Input[/align]
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input.
This test case is not to be processed.

[align=left]Output[/align]
Print the total time on a single line for each test case.

[align=left]Sample Input[/align]

1 2
3 2 3 1
0


[align=left]Sample Output[/align]

17
41


[align=left]Author[/align]
ZHENG, Jianqiang

题解:
从0层开始,上一层花6s,下一层花4s,每个数的楼层停5s。
简单模拟一下。

AC代码:

#include<iostream>
#include<cstdio>
int main()
{
int n,k,t,s,i;
while(~scanf("%d",&n)){
k=n;
t=0;  //时间
s=0; //楼层
if(n==0)break;
while(n--){
scanf("%d",&i);
if(i-s>=0){
t=t+6*(i-s);
s=i;
}
if(s-i>=0){
t=t+4*(s-i);
s=i;
}
}
printf("%d\n",t+5*k);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: