您的位置:首页 > 其它

杭电5655 CA Loves Stick

2016-04-04 19:25 387 查看


CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 695    Accepted Submission(s): 245


Problem Description

CA loves to play with sticks.

One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.

(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
 

Input

First line contains T denoting
the number of testcases.
T testcases
follow. Each testcase contains four integers a,b,c,d in
a line, denoting the length of sticks.
1≤T≤1000, 0≤a,b,c,d≤263−1

 

Output

For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).

 

Sample Input

2
1 1 1 1
1 1 9 2

 

Sample Output

Yes
No

 

Source

BestCoder Round #78 (div.2)

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  5659 5658 5657 5656 5654 

 
判断给的4条长度能不能构成一个四边形,也就是说最长的一条边的长度是不是小与其他三条边的长度和,由于数据太大,所以要用unsigned 和一个减法:
本想用除法的但是这样不是很对:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
unsigned __int64 a[5],i,j,k,l,m,n;
int main()
{
int p;
scanf("%d",&p);
while(p--)
{
for(i=0;i<4;i++)
scanf("%I64d",&a[i]);
sort(a,a+4);
if(a[0]==0)
{
printf("No\n");
continue;
}
if(a[0]+a[1]>a[3]-a[2])
printf("Yes\n");
else
printf("No\n");
//double help=a[1]*1.00/4+a[2]*1.00/4+a[0]*1.00/4;
//double cnt=a[3]*1.00/4;

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 数学题 ca