您的位置:首页 > 产品设计 > UI/UE

hdu 1711 Number Sequence

2016-04-04 11:02 423 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 19065 Accepted Submission(s): 8186



[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


[align=left]Sample Output[/align]

6
-1


[align=left]Source[/align]
HDU 2007-Spring Programming Contest

[align=left]Recommend[/align]
lcy | We have carefully selected several similar problems for you: 1686 1251 2222 1867 2203

Statistic | Submit | Discuss
| Note

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 1000003
#define M 10003
using namespace std;
int n,m,t[M],num;
int s1
,s[M];
void calc()
{
t[0]=-1; int j;
for (int i=0;i<m;i++)
{
j=t[i];
while(j!=-1&&s[i]!=s[j])  j=t[j];
t[i+1]=++j;
}
}
int solve()
{
int i=0,j=0;
while (i<n)
{
if (j==-1||s1[i]==s[j])
i++,j++;
else j=t[j];
if (j==m)  return i-j+1;
}
return -1;
}
int main()
{
scanf("%d",&num);
for (int i=1;i<=num;i++)
{
scanf("%d%d",&n,&m);
for (int j=0;j<n;j++)
scanf("%d",&s1[j]);
for (int j=0;j<m;j++)
scanf("%d",&s[j]);
calc();
printf("%d\n",solve());
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: